IDCategoryTask Type  ascPrioritySeveritySummaryStatusProgress
29Backend / CoreBug ReportVery LowCriticalMac version Keeps CrashingUnconfirmed
Task Description

Dear EDuke32 Support,

I seem to have trouble playing EDuke32 on my MacBook Pro. I have the official GOG version and playing it by itself is okay but when I use EDuke32 the game would crash. This seems to only happen when I play the game the second time. The game screen turns black, my Mac makes this buzzing sound and nothing happens. I had no choice but to press the power button to restart my Mac.

The following are the details of my Mac (also attached is my System Report for your perusal):

OS X El Capitan (v 10.11.6)
MacBook Pro (15-inch, Late 2011)
Processor: 2.2 GHz Intel Core i7
Memory: 8 GB 1600 MHz DDR3
Startup Disk: Macintosh HD
Graphics: AMD Radeon HD 6750M 512 MB

Several things I tried doing to solve the problem:

  1. I followed the EDuke32 wiki page and copied the DUKE.RTS and DUKE3D.GRP files (which I got from the PC version of Duke3D GOG) into the [Application Support –> EDuke32 folder]. It works but again it crashes on the second playthrough.
  2. I copied the EDuke32 app into the Duke 3D GOG app (Duke Nukem –> Show Package Contents –> Contents –> Resources) and once again, it only works on the first playthrough.

I used the OS X Lion version of EDuke32 (eduke32_osx-sdl2_lion_svn5811.dmg | The Jul 12 2016 version) to play the game. What am I doing wrong? Or is there an actual bug on the Mac version?

Appreciate if anyone can help identify the problem and provide a solution to it.

Hope to hear from you promptly.


32Backend / CoreBug ReportVery LowCriticalr4897 introduces startup crash on some architecturesUnconfirmed
Task Description

I have been using r5485 32 bit for some time on a modern laptop (i7, 12GB, Intel HD 4.3.0 / GTX 850) for some time. Copied EDuke32 installation to my backup laptop (i3, 4GB, very basic Intel graphics) and it crashes on startup. I get some OpenGL feature-not-present warnings, as expected for a machine of this age/class, but wasn’t expecting it to crash.

Bisected timeline using debug builds, change was introduced in r4897; previous build works fine. Tested with out-of-the-box install, no HRP, no addons, no settings changes. Extract, copy in atomic duke3d.grp, run eduke32, click start button in startup dialog making no settings changes whatever.

Crash log, CPU-Z and MSINFO32 reports attached.

61Backend / CoreBug ReportVery LowCriticalCrash during sound initialisation r6301 with map from a...Unconfirmed
Task Description


With vanilla 1.5 duke3d and no other files loaded
Crash during sound initialisation.
This also happens using v1.3d .grp file as well.
Please find attached full crash log (from debugging build) and copy of map.

Critical part of log:

Initializing sound... 32 voices, 2 channels, 16-bit 48000 Hz
g_errorLineNum: 0, g_tw: 0
73Backend / CoreBug ReportVery LowCriticalEduke32 source code won't compile (revision 7138, 3 Nov...Unconfirmed
Task Description

The attached log demonstrates that the current revision (7138, 3 November 2018) of eDuke32’s source code will not compile on my machine. I’m using gcc 5.4.0 on Ubuntu 16.04 64-bit. See the attached terminal log.

In fact, eDuke32 has not compiled for me since revision 7078 (16 October 2018), though the source file that gives the error and the compiler message has changed since then. I attach a log of that as well in case that helps.

4Backend / CoreBug ReportVery LowHighController IssuesUnconfirmed
Task Description

Using a gamepad results in odd behavior. There is always a tilt to Duke’s movements, or to put it another way there is no zero. Changing the sensitivity offsets this, but the sensitivity also reveals how out of balance it is. at 26% and below it leans to the left, and at 27% and above it leans to the right. It also appears to completely ignore the existence of the second stick, using it as four buttons rather than...well, a stick. Oddly, it still shows up as an axis in the joystick settings, though modifying it does nothing.

20Backend / CoreBug ReportVery LowHighWarping in overlapping sectorsUnconfirmed
Task Description

Something that’s become a rather large problem as of late are enemies, objects, and even myself, the player, just glitching through overlapping sectors in that fake room-over-room style. This isn’t just an effect on fan-maps; official maps such as L.A. Rumble and especially Tier Drops and Lunatic Fringe (in the case of the latter it being the difference between you escaping with your life and then being teleported right back into danger to be perforated by a Battlelord) suffer from it as well.

24Backend / CoreBug ReportHighHighPerfect Ornamented SpritesResearching
Task Description

Hardware accelerated renderers need wall-aligned and floor-aligned sprites to get ornamented to surfaces with no clipping or performance regressions.

41Backend / CoreBug ReportVery LowHighPlayer gibs on spawn, even in fake multiplayerUnconfirmed
Task Description

This is a known bug, but I think I may know why it’s happening.

In fake MP (either with bots or not) players (usually the first player and one other) will end up gibbing on spawn. I’ve noticed that sometimes you’ll end up seeing your view move on it’s own, as if you’re being “controlled” by another player. I’m wonder if this long-standing bug might be because two players are trying to occupy the same body and are sharing input, or at least being tied to the same spawn, thus the weird “being taken control of” bug and the telefragging on spawn.

I’ve also noticed that the first player doesn’t spawn in the initial spawn point (brown arrow in mapster32) at the start of a map like they are normally supposed to either.

I know the multiplayer is far from complete, but I hope this could at least be looked at in the interim so I can at least play some botmatches.

71Backend / CoreBug ReportVery LowHighproblems with midi music in linuxUnconfirmed
Task Description

Hello everyone starting from the version 20180129-6627 there are problems with the midi music in linux. My operating system is Arch Linux. The latest version of duke32 that works well is 20180128.r6613. You can do some tests with this package:

82Backend / CoreBug ReportVery LowHighPolymer HUD Weapon misaligned as of s7333Unconfirmed
Task Description forum thread:

90Backend / CoreBug ReportVery LowHighTrapped in Toxic Dump shrink roomUnconfirmed
Task Description


I downloaded eduke32 rev 8075 and compiled on linux and started playing Duke Nukem 3D.

It worked great and was fun until I reached level “Toxic Dump” with the shrink room: At some point you get a red key card which unveils a shrinker. You have to run shrunk through a small tunnel into another room with a shrinker. In that room there’s a switch which opens a door outside. The only way to enter and to leave that room is shrunk. So you need the shrinker in that room to get out again. With rev 8075 it is not possible because the shrinking beam doesn’t leave the wall. You’re trapped.

I checked out a couple of older revisions (which had issues with incompatible savefile versions and stuff). I ended up with revision 7500 that worked for me. With revision 7500 the shrink beam leaves the wall, I could get shrunk and leave the room. After getting past this point I saved and got back to revision 8075.

I attached a savefile where you in the shrink room. Just load it with revision 7500 and 8075 and you will see the difference with the shrink beam.

92Backend / CoreBug ReportVery LowHighSource code fails to compile with clang since r8396Unconfirmed
Task Description

See attached log. Tested with clang 8.0.1 and 9.0.1-rc2.

8Backend / CoreBug ReportVery LowMediumView clipping glitchUnconfirmed
Task Description

I notice at certain points in certain levels active sprites will disappear and you can see through walls. Attached are a series of screenshots showing the precise location I was able to intentionally make this happen in E2L4. Standing on the edge of the bridge object, which is embedded within the geometry a little bit, seems to be a repeatable way to get this reaction. I have, however, triggered it unintentionally far more but because it happens for but an instant I am unable to screencap fast enough.

I wasn’t sure if this was related to the other sprite issues, but I saw no mention of the clipping so I reported this by itself.

22Backend / CoreBug ReportVery LowMediumTexture rendering issue with PolymerUnconfirmed
Task Description

I’m noticing some textures being clipped when looked at from certain angles. There’s a good example of this in Hollywood Holocaust with the Sister Act II poster with in the theater with the lights on. Whenever I look around the area from a certain angle, the poster would get cut off in weird ways.

25Backend / CoreBug ReportVery LowMediumMissing World Geometry Using Polymer RendererUnconfirmed
Task Description

In some levels with the Polymer renderer being used, world geometry will not be drawn, with the sky showing through these openings. It has a tendency to happen on certain maps, but can also happen completely at random. I took the screenshots from the first level of NAM because it is basically right in front of you when you start and happens every single time. I have also encountered situations where geometry that was present will not be present when a level is saved and loaded.

36Backend / CoreBug ReportVery LowMediumTROR editing camera jumpingUnconfirmed
Task Description

When editing some walls in mapster, such as inserting new points or dragging points around, this often causes the camera to jump vertically. This usually has an effect on the vertical editing zone that you’ve created by pressing ctrl-r while a sector is highlighted, causing everything to become greyed out which slows down mapping. It’s also annoying to have to return to the room you’re working on in 3D mode after a jump. Obviously this happens in areas where you have sectors stacked on top of each other.

45Backend / CoreBug ReportVery LowMediumController issues, againUnconfirmed
Task Description

Several issues with controllers:

- Double tap commands set by default cannot be unbound, even by editing the file settings with a text editor. This is a bug I noticed in 2010 AFAIK and that is still occurring in 2016!
- With an Xbox 360 controller, Axis 3 and 4 are respectively bound to Axis 0 and 1, meaning that two commands are bound to the same analog stick. Also, setting a correct sensitivity in order to not to have Duke spinning as hell is nearly impossible.

54Backend / CoreBug ReportVery LowMediummultiplayer- viewscreens teleportUnconfirmed
Task Description

using a viewscreen in multiplayer teleports you to where the camera is

55Backend / CoreBug ReportVery LowMediummultiplayer - some actions out of syncUnconfirmed
Task Description

for example I run 2 players on my PC, level 1 opened the curtains and blew a hole in the movie screen. the player that did this could se the curtains open as per normal but the other player saw the curtains still closed, but could see player 1 walk through

56Backend / CoreBug ReportVery LowMediumEDuke32 does not obey NVidia Control Panel's Color Sett...Unconfirmed
Task Description

Basically, with my new laptop, the screen’s default color calibration is off from normal, and I don’t got the $ to try to gamble on replacing the screen with a better one, so I used NVidia Control Panel’s individual color settings to offset the colors [mostly the blue part] to more acceptable colors. Unfortunately, under normal circumstances, loading EDuke32/Mapster32 will force the old color calibration settings while running it [and only while the window is selected, as it will show the proper color calibration outside of it].

The only workaround I’ve come up with for this is to setting the in-game/engine Contrast to 0.0 in the console [”vid_contrast 0”] which somehow re-inforces my Control Panel Color settings over EDuke32, however this does weird things to the gamma setting in certain ranges [like between 0.85 and 1.17, the screen will be very faded out, while otherwise, the game is brighter than normal gamma and changing it has very little effect], so you don’t have as fine tuned control over it as you’d like, and brightness is completely uneditable when the contrast is 0 too.

Another issue is even if I do this in Mapster32, going into 2D mode always unsets the contrast in 2D mode and thus forces the original screen color calibration, forcing me to set the contrast to 0 for 2D mode each time. It also doesn’t seem to save the 3D mode contrast when I leave the program, so I have to reset it once for 3D mode each time I run Mapster32.

62Backend / CoreBug ReportVery LowMediumEduke32 doesn't remember vsync on setting when starting...Unconfirmed
Task Description

When starting eduke32(with polymer HRP) and then start a saved game, the game will start with vsync off.
Though in the menu its on.
Turning vsync in the menu off and on again, will solve this problem.
This only happens when starting saved games, directly after eduke32 started.
With new games there is no problem.

74Backend / CoreBug ReportVery LowMediumDuke Nukem Atomic Edition eDuke32 v 7335 crashes on dem...Unconfirmed
Task Description

Problem may happen due to custom controls?


1. Delete all *.edm files or backup them in such way that game is not going to see them.
2. Start eDuke32 Atomic Edition (eduke v7335)
3. Go to game options and turn recording on.
4. Start new game (L.A. Meltdown with Come get some difficulty)
5. Play the game for >3s.
6. Go to Game options and turn demo recording off.
7. Quit to title.


1. Intro animation,
2. Recoded demo loads and starts to play,
3. Demo crashes after <3s of playback,
4. Crash causes game to quit to system desktop.

Please see attached demo that crashes and log file.

86Backend / CoreBug ReportVery LowMediummdzoff maphack issue for floor aligned modelsUnconfirmed
Task Description EDuke32 forum thread 775 / post #5383 ff:

5Backend / CoreBug ReportVery LowLowSprites disappearing/acting weird in Polymost rendererAssigned
Task Description

Yeah... I recorded those bugs in action, with is RED2 (2014 remake) again. :P

Missing alphabet sprites(the WC “sign” just disappeared so I forgot that’s a goddamn WC room when I play the new version of map), and gaps on the both sides of security camera “box”......

Classic renderer just fine...

It seems many maps with sprites may have such issues...and sometimes will randomly happens after played some levels in eduke32 about half-hour and more.

9Backend / CoreBug ReportVery LowLowLevitating SpritesUnconfirmed
Task Description

I’ve noticed certain sprites (it appears to be random) will appear at a level significantly higher than where they’re supposed to be. Attached is a picture of a fire floating freely through the air. I have observed enemy sprites do this as well. I’m not sure where their collision box is.

This is so far in the software render. Untested with graphic acceleration.

10Backend / CoreBug ReportVery LowLowSpecular maps affected too directly by scene lightingUnconfirmed
Task Description

As per the summary specular maps are too heavily effected by the scene lighting which results in an almost pearlescent paint effect.

17Backend / CoreBug ReportVery LowLowSprite Layering IssueUnconfirmed
Task Description

Object sprites have a strong tendency to be rendered behind special objects and in front of level geometry.

27Backend / CoreBug ReportVery LowLow64-bit version doesn't use the system MIDI deviceUnconfirmed
Task Description

Windows 8.1 x64. The default MIDI device is loopMidi.
Works fine with 32-bit EDuke32 and other applications like DosBox, but the 64-bit EDuke32 uses some primitive synthesizer instead. loopMidi shows zero throughput.

30Backend / CoreBug ReportVery LowLowWindow size limitUnconfirmed
Task Description

My monitor’s native resolution is 2560×1600. Fullscreen works perfectly fine, but the highest windowed resolution I can set is 1920×1440.

Manually changing the config doesn’t work. What does work is starting the game in fullscreen, then pressing Alt+Enter, resulting in a borderless fullscreen window.

34Backend / CoreBug ReportVery LowLowaddons folderUnconfirmed
Task Description


actually I have two way to launch addons with eduke 32:

1) put all fikes (grp and maps) into the eduke32 main folder or in the config folder.
2) launch eduke32 with -j /full_path_to_folder_with_grp

Could you add another cleaner way please?

Like this one:

Eduke could search for an /addons folder located in his main folder (executable folder) or in his config folder (/home/username/.eduke32 for linux).

40Backend / CoreBug ReportVery LowLowMenu/Interface GlitchAssigned
Task Description

EDuke menu captions doesn’t support non-latin symbols (because font is a pile of tiles representing only latin symbols, digits and some punctuation marks). If I go under “User Map” menu section, browse file system with internal file explorer and find a folder/file with non-latin symbols in its name, I get a glitch (wrong tile in place of non-latin symbol), because of an incorrect offset. I attach a screenshot of this glitch.

49Backend / CoreBug ReportVery LowLowSetting effects volume to 56% or less kills certain sou...Unconfirmed
Task Description

This bug started in revision 3997:

If you set your effects volume to 56% or less, certain sounds refuse to work. Glass breaking, toilet/hydrant water gurgling, breaking glass and bottles, etc... just go completely dead silent.

50Backend / CoreBug ReportVery LowLoweduke32 command line: relative path Unconfirmed
Task Description


when I launch addons with eduke 32, in a command line, I have to specify the full path.

Is it possible to add relative path (the executable is the source).

Thank you for your help.

52Backend / CoreBug ReportVery LowLowMap shade preview does not restore pal/shade when disab...Unconfirmed
Task Description

no task description

53Backend / CoreBug ReportVery LowLowCommand line options, difficulty settingsUnconfirmed
Task Description

-s command line parameter doesn’t seem to work, it doesn’t change the difficulty (skill) in settings.cfg; I can only change it via game menu by starting new game with the difficulty I want.
Also, if I launch the game with -s4 (Damn I’m Good, respawning enemies), then it doesn’t change the difficulty (in terms of enemies/objects placement) but enemies WILL respawn.

58Backend / CoreBug ReportVery LowLowPipebombs thrown from the water's surface stay on the s...Unconfirmed
Task Description

Using Eduke32 20170423-6129, Go into Raw Meat (E3L1) and throw pipebombs into the pool of water using the classic renderer with mouse vertical aiming off.

1. If you throw a pipebomb from the grass into the water, it will sink into the water
2. If you throw a pipebomb while you’re floating on the surface, it will “stay” on the surface.

You can see a small pipebomb sprite on the surface of the water when this happens, but only in the classic renderer.

This happens in the latest build of Eduke32.

63Backend / CoreBug ReportVery LowLowEVENT_ANALYZESPRITES does not work in mapster32Unconfirmed
Task Description

This code should change the tile picnum during the deplay process. In the old version (Mapster32 2.0.0devel r4488 (32-bit) Compiled May 28 2014 15:48:34), this method works correctly. In the version (Mapster32 r6332 Built Jul 6 2017 07:49:55, GCC 6.3.0, 32-bit) it does not work.

    for i drawnsprites {
        ife tsprite[i].picnum ITEM {
            ifg tsprite[i].extra 0 set tsprite[i].picnum tsprite[i].extra
64Backend / CoreBug ReportVery LowLowSmall memory leaks fixUnconfirmed
Task Description

Hi here a little patch proposal to fix small mem leaks found. Cheers.

66Backend / CoreBug ReportVery LowLowloading a savegame removes level lightsUnconfirmed
Task Description

i loaded up the duke burger level via the console (changelevel 4 2), saved the game immediately, and proceeded to take a screenshot with fraps
the first screenshot shows the level on first load , showing level lights and dynamic lights

then i reloaded the savegame and took another screenshot
the other screenshot shows the level after reloading , showing only dynamic lights with missing level lights

67Backend / CoreBug ReportVery LowLowLink errors after svn update without make cleanUnconfirmed
Task Description

Hello, everyone. After updating my working copy of the source code from revision 6688 to 6722, I attempted to make the executables, and got many link errors. This implies that the makefile does not adequately list the dependencies for each object file. I enclose my terminal output. It worked fine after I ran a make clean.

68Backend / CoreBug ReportVery LowLow-m doesn't disable enemiesUnconfirmed
Task Description

In the eduke32 -help output as well as in the online wiki, it is documented that:

eduke32 -m

should disable all monsters. But it doesn’t.

I have attached the output log.

69Backend / CoreBug ReportVery LowLowRidiculous number of enemies left in Lunar Apocalypse->...Unconfirmed
Task Description

After completing Fusion Station, the game report that I left 65425 enemies. Is this an error?

The problem is reproducible on my machine.

A 34 meg video is available if you want to see it. I recorded it on my iPad and took a freezeframe from it for you to see here.

72Backend / CoreBug ReportVery LowLowDialogue missing during Episode 3 ending Unconfirmed
Task Description

At the end of Episode 3, after completing the Stadium boss fight and watching the cutscene, Duke merely says “My name is Duke Nukem”, instead of the expected full speech “My name is Duke Nukem, after a few days R&R...(etc)”

I have tested this using a clean install of the latest build (EDuke32 r7067
Built Oct 10 2018 14:07:44, GCC 7.2.0, 64-bit)

78Backend / CoreBug ReportVery LowLoweduke32.log: meaningful message about incompatible save...Unconfirmed
Task Description

The current message is almost useless for average users:
“Incompatible file version. Expected 1.7.340.0.9a65a44c, found 1.3.310.8.0” - Hm, what file are they talking about? -
And it should not show up on each and every save/load action, but only on game startup.
Better message:
“Incompatible version of saved game file dukesav0.esv: Expected 1.7.340.0.9a65a44c, found 1.3.310.8.0”

79Backend / CoreBug ReportVery LowLoweduke32.log: do not endlessly repeat the same messages ...Unconfirmed
Task Description

If you appreciate community members to help casual players with simple issues, please try to make our life easier on occasion.
In this case I’m referring to the sound files defined in USER.CON, but missing in regular DUKE3D.GRP.
This applies to FS#78 as well, for example.

83Backend / CoreBug ReportVery LowLowPolymost regression - floor aligned spritesUnconfirmed
Task Description thread

84Backend / CoreBug ReportVery LowLowvent problem when runspeed < defaultUnconfirmed
Task Description forum thread:

91Backend / CoreBug ReportVery LowLowAdding FreeBSD support Unconfirmed
Task Description

Please consider adding support for FreeBSD by updating “source/build/include/zpl.h” to the latest ZPL version (GitHub commit 26753e04e9ed08dff55a5998a085ca2996d1775f) and applying the following patch. EDuke32 then compiles on FreeBSD as well with:

$ gmake -f GNUmakefile L=/usr/local/lib/ I=/usr/local/include/ BUILD32_ON_64=1 CLANG=1
--- zpl.h	2019-11-01 05:35:57.095504000 +0100
+++ zpl_new.h	2019-11-01 05:50:39.201436000 +0100
@@ -520,10 +520,16 @@
 #include <stdlib.h> // NOTE: malloc on linux
 #include <sys/mman.h>
-#if !defined(ZPL_SYSTEM_OSX)
+#if !defined(ZPL_SYSTEM_OSX) && !defined(ZPL_SYSTEM_FREEBSD)
     #include <sys/sendfile.h>
+#if defined(ZPL_SYSTEM_FREEBSD)
+    #include <sys/types.h>
+    #include <sys/socket.h>
+    #include <sys/uio.h>
 #include <dirent.h>
 #include <sys/stat.h>
 #include <sys/time.h>
@@ -767,6 +773,11 @@
+#if defined(ZPL_SYSTEM_FREEBSD)
+    #define ZPL_EXTERN extern
+    #define zpl_inline inline
 #if !defined(zpl_no_inline)
     #if defined(_MSC_VER)
         #define zpl_no_inline __declspec(noinline)
@@ -1557,7 +1568,7 @@
     zpl_isize threads_per_core;
 } zpl_affinity;
-#elif defined(ZPL_SYSTEM_LINUX) || defined(ZPL_SYSTEM_EMSCRIPTEN)
 typedef struct zpl_affinity {
     zpl_b32   is_accurate;
@@ -6967,7 +6978,7 @@
-#if defined(ZPL_SYSTEM_LINUX)
+#if defined(ZPL_SYSTEM_LINUX) || defined(ZPL_SYSTEM_FREEBSD)
 zpl_inline zpl_f64 zpl__unix_getime(void) {
     struct timespec t;
     zpl_f64 result;
@@ -8152,7 +8163,7 @@
     return a->threads_per_core;
-#elif defined(ZPL_SYSTEM_LINUX)
+#elif defined(ZPL_SYSTEM_LINUX) || defined(ZPL_SYSTEM_FREEBSD)
 // IMPORTANT TODO: This zpl_affinity stuff for linux needs be improved a lot!
 // NOTE(zangent): I have to read /proc/cpuinfo to get the number of threads per core.
@@ -10816,7 +10827,11 @@
     struct stat stat_existing;
     fstat(existing_fd, &stat_existing);
+#if defined(ZPL_SYSTEM_FREEBSD)
+    size = sendfile(new_fd, existing_fd, 0, stat_existing.st_size, NULL, 0, 0);
     size = sendfile(new_fd, existing_fd, 0, stat_existing.st_size);
38Backend / CoreBug ReportVery LowVery LowHardcoded actor bugUnconfirmed
Task Description

Hrdcoded SLIMER actor bugged behaviour: When you shoot FREEZEBLAST at SLIMER, it freezes, but actors_killed variable increments at the same time. Thus you can increase actors_killed value by freezing/thawing SLIMER over and over.
actor.c: line 4336 should be moved after “if” statement at line 4341 (don’t increment actors_killed if slimer was freezed);
actor.c: line 4336 should be copied right after the line 4215 (increment actors_killed if frozen slimer is shattered);

42Backend / CoreBug ReportVery LowVery Low"Duke Talk" Sound block should be per-actor, not global...Unconfirmed
Task Description

Sounds with the Duke Talk bit enabled have a bit of code that blocks another Duke Talk sound from playing if any Duke Talk is already playing. This is normal, but there’s a bit of a bug/oversight with it. With the way it is now, in Multiplayer, only one player can play pain or death sounds at a time. If someone is being damaged, it’ll block other players from making noise. Same can happen in singleplayer if you have useractor that uses Duke Talk. What I suggest, is adding an additional check so it blocks on a per-actor basis, so only one sound can play per actor, and not one sound globally. This check wouldn’t apply if GlobalSound is being used, however, for obvious reasons.

Showing tasks 1 - 50 of 67 Page 1 of 21 - 2 -

Available keyboard shortcuts


Task Details

Task Editing