ID  descCategoryTask TypePrioritySeveritySummaryStatusProgress
103Backend / CoreBug ReportVery LowLow ALT-strafing is brokenUnconfirmed
Task Description

As of r8551, while ALT is pressed, Duke moves into the opposite direction of the used right/left arrow key. ALT-mouse strafing is still OK.

102Backend / CoreBug ReportVery LowLowBacktrace DLLs fail to build on Win10/MSYS2Unconfirmed
Task Description

“make ebacktrace” fails on current Win10/MSYS2. And the DLLs shipped with EDuke32 are more than five years old, actually.

Fix (64bit):
> pacman -S mingw-w64-x86_64-expat mingw-w64-x86_64-gettext

Working command line (64bit):
> gcc -O2 -std=gnu99 -ggdb -shared -Wall -Wextra -static-libgcc -o ebacktrace1-64.dll platform/Windows/src/backtrace.c -I/mingw64/include/binutils/ -L/mingw64/lib/binutils/ -lbfd -liberty -limagehlp -lintl
(I’m using “-Og” instead of “-O2 -std=gnu99” locally)

Fixing the make files accordingly should be easy.

101Backend / CoreBug ReportVery LowVery Lowcase mismatch warning inconsistencyUnconfirmed
Task Description

Current EDuke32 version: r8534

System: Win10 / NTFS


map file: .\E1L1.MAP
cmd line: eduke32 -map
> Using level: “/”.

map file: .\
cmd line: eduke32 -map E1L1.MAP
> warning: case mismatch: passed “E1L1.MAP”, real “” > Using level: “/E1L1.MAP”.

100Backend / CoreBug ReportVery LowMediumNew jump-duck cheat in E1L1Unconfirmed
Task Description

As of r8096, you can jump-duck through the box office window in E1L1: HOLLYWOOD HOLOCAUST

It becomes even easier in later versions like r8130.

Current version: r8534 forum post :

99Backend / CoreBug ReportVery LowMediumTROR Bug when standing on a spriteUnconfirmed
Task Description forum threads :

98Backend / CoreFeature RequestVery LowLowobject property inheritanceUnconfirmed
Task Description

Spawned objects should inherit the maphacked properties of their parent.
( tile0009 respawn, canwithsomething[2|3|4], ... )

97Backend / CoreBug ReportVery LowLowEnvironment palette not set/restoredUnconfirmed
Task Description forum thread :

(As of now I can’t reproduce the occurrence when starting an episode’s next level after finishing the previous one under water.)

96Backend / CoreBug ReportVery LowHighImpossible to get crushed by enemies when shrunkUnconfirmed
Task Description forum thread :

95Backend / CoreBug ReportVery LowLowSprite Ladders BrokenUnconfirmed
Task Description

Sprite ladders seem broken as of r7831 forum thread :

94Backend / CoreBug ReportVery LowHighDucking BehaviourUnconfirmed
Task Description forum thread :

93Backend / CoreBug ReportVery LowHighFlipped HUD models not drawn in PolymostUnconfirmed
Task Description EDuke32/Bug Reports forum thread 10977:

92Backend / CoreBug ReportVery LowHighSource code fails to compile with clang since r8396Unconfirmed
Task Description

See attached log. Tested with clang 8.0.1 and 9.0.1-rc2.

91Backend / CoreBug ReportVery LowLowAdding FreeBSD support Unconfirmed
Task Description

Please consider adding support for FreeBSD by updating “source/build/include/zpl.h” to the latest ZPL version (GitHub commit 26753e04e9ed08dff55a5998a085ca2996d1775f) and applying the following patch. EDuke32 then compiles on FreeBSD as well with:

$ gmake -f GNUmakefile L=/usr/local/lib/ I=/usr/local/include/ BUILD32_ON_64=1 CLANG=1
--- zpl.h	2019-11-01 05:35:57.095504000 +0100
+++ zpl_new.h	2019-11-01 05:50:39.201436000 +0100
@@ -520,10 +520,16 @@
 #include <stdlib.h> // NOTE: malloc on linux
 #include <sys/mman.h>
-#if !defined(ZPL_SYSTEM_OSX)
+#if !defined(ZPL_SYSTEM_OSX) && !defined(ZPL_SYSTEM_FREEBSD)
     #include <sys/sendfile.h>
+#if defined(ZPL_SYSTEM_FREEBSD)
+    #include <sys/types.h>
+    #include <sys/socket.h>
+    #include <sys/uio.h>
 #include <dirent.h>
 #include <sys/stat.h>
 #include <sys/time.h>
@@ -767,6 +773,11 @@
+#if defined(ZPL_SYSTEM_FREEBSD)
+    #define ZPL_EXTERN extern
+    #define zpl_inline inline
 #if !defined(zpl_no_inline)
     #if defined(_MSC_VER)
         #define zpl_no_inline __declspec(noinline)
@@ -1557,7 +1568,7 @@
     zpl_isize threads_per_core;
 } zpl_affinity;
-#elif defined(ZPL_SYSTEM_LINUX) || defined(ZPL_SYSTEM_EMSCRIPTEN)
 typedef struct zpl_affinity {
     zpl_b32   is_accurate;
@@ -6967,7 +6978,7 @@
-#if defined(ZPL_SYSTEM_LINUX)
+#if defined(ZPL_SYSTEM_LINUX) || defined(ZPL_SYSTEM_FREEBSD)
 zpl_inline zpl_f64 zpl__unix_getime(void) {
     struct timespec t;
     zpl_f64 result;
@@ -8152,7 +8163,7 @@
     return a->threads_per_core;
-#elif defined(ZPL_SYSTEM_LINUX)
+#elif defined(ZPL_SYSTEM_LINUX) || defined(ZPL_SYSTEM_FREEBSD)
 // IMPORTANT TODO: This zpl_affinity stuff for linux needs be improved a lot!
 // NOTE(zangent): I have to read /proc/cpuinfo to get the number of threads per core.
@@ -10816,7 +10827,11 @@
     struct stat stat_existing;
     fstat(existing_fd, &stat_existing);
+#if defined(ZPL_SYSTEM_FREEBSD)
+    size = sendfile(new_fd, existing_fd, 0, stat_existing.st_size, NULL, 0, 0);
     size = sendfile(new_fd, existing_fd, 0, stat_existing.st_size);
90Backend / CoreBug ReportVery LowHighTrapped in Toxic Dump shrink roomUnconfirmed
Task Description


I downloaded eduke32 rev 8075 and compiled on linux and started playing Duke Nukem 3D.

It worked great and was fun until I reached level “Toxic Dump” with the shrink room: At some point you get a red key card which unveils a shrinker. You have to run shrunk through a small tunnel into another room with a shrinker. In that room there’s a switch which opens a door outside. The only way to enter and to leave that room is shrunk. So you need the shrinker in that room to get out again. With rev 8075 it is not possible because the shrinking beam doesn’t leave the wall. You’re trapped.

I checked out a couple of older revisions (which had issues with incompatible savefile versions and stuff). I ended up with revision 7500 that worked for me. With revision 7500 the shrink beam leaves the wall, I could get shrunk and leave the room. After getting past this point I saved and got back to revision 8075.

I attached a savefile where you in the shrink room. Just load it with revision 7500 and 8075 and you will see the difference with the shrink beam.

89Backend / CoreFeature RequestVery LowVery LowUpdated Blender md3 export script availableUnconfirmed
Task Description

eduke32/source/tools/src/ forum thread:

88Backend / CoreBug ReportVery LowVery Lowdistorted floor aligned sprites in Mapster32 2D viewUnconfirmed
Task Description forum thread 8241 / post #19:

87Backend / CoreFeature RequestVery LowMediumHave only one configuration file per executableUnconfirmed
Task Description

Maybe read the other format if the default is missing, but this schism really has to go.

86Backend / CoreBug ReportVery LowMediummdzoff maphack issue for floor aligned modelsUnconfirmed
Task Description EDuke32 forum thread 775 / post #5383 ff:

85Backend / CoreFeature RequestVery LowLownew maphack tokensUnconfirmed
Task Description

These would help to make (user) maps look better HRP-wise:
- a flip token to flip highres wall textures vertically/horizontally (why not for models/voxels as well)
- a lowres token, similar to notmd, to use the ART instead of the highres tile to improve backwards compatibility to mapper’s sprite art.

84Backend / CoreBug ReportVery LowLowvent problem when runspeed < defaultUnconfirmed
Task Description forum thread:

83Backend / CoreBug ReportVery LowLowPolymost regression - floor aligned spritesUnconfirmed
Task Description thread

82Backend / CoreBug ReportVery LowHighPolymer HUD Weapon misaligned as of s7333Unconfirmed
Task Description forum thread:

81Backend / CoreFeature RequestVery LowLowAdd Transfusion's art2tga to EDuke32 toolsUnconfirmed
Task Description

This little tool is really handy and GPL‘d.
I have attached an updated source code with the Duke3D palette added and set as the default, so that it works standalone without PALETTE.DAT.

80Backend / CoreFeature RequestVery LowLoweduke32.log: suppress CON code warnings about official ...Unconfirmed
Task Description

Current example: the two “‘else’ with no ‘if’” warnings in Atomic GAME.CON.
Better show only one message instead (FOOBAR.CON’s checksum is known):
“Note: suppressing warnings about CON code in well-known FOOBAR.CON”

If possible, the check for missing sound files in USER.CON (see FS#79) should be moved to CON compile time. Then this can be handled like above.

79Backend / CoreBug ReportVery LowLoweduke32.log: do not endlessly repeat the same messages ...Unconfirmed
Task Description

If you appreciate community members to help casual players with simple issues, please try to make our life easier on occasion.
In this case I’m referring to the sound files defined in USER.CON, but missing in regular DUKE3D.GRP.
This applies to FS#78 as well, for example.

78Backend / CoreBug ReportVery LowLoweduke32.log: meaningful message about incompatible save...Unconfirmed
Task Description

The current message is almost useless for average users:
“Incompatible file version. Expected 1.7.340.0.9a65a44c, found 1.3.310.8.0” - Hm, what file are they talking about? -
And it should not show up on each and every save/load action, but only on game startup.
Better message:
“Incompatible version of saved game file dukesav0.esv: Expected 1.7.340.0.9a65a44c, found 1.3.310.8.0”

77Backend / CoreBug ReportVery LowVery Lowmapster32.log: no longer warns about missing names.hUnconfirmed
Task Description

Message “Failed to open names.h” is lost as of r5414.

76Backend / CoreBug ReportVery LowVery Lowmapster32.log: "Found no recognized game data!" despite...Unconfirmed
Task Description

This message shows up unconditionally as of r4557, while eduke32.log is fine.

75Backend / CoreBug ReportVery LowVery LowErroneous CON parser warningUnconfirmed
Task Description

A nullop in brackets may cause a “`nullop’ found without `else’” warning.
Btw, is there a reason why the citations start with ` instead of ' ?

This legit construct can be easily avoided be removing the brackets, but is surely handy during development.

Example (World Tour):

Including: EPISODE5BOSS.CON (8197 bytes)
EPISODE5BOSS.CON: In state `BOSS5code’:
EPISODE5BOSS.CON:377: warning: `nullop’ found without `else’

    ifhitweapon {
      ifwasweapon FLAMETHROWERFLAME {
      else {
        state checkBOSS5hitstate
74Backend / CoreBug ReportVery LowMediumDuke Nukem Atomic Edition eDuke32 v 7335 crashes on dem...Unconfirmed
Task Description

Problem may happen due to custom controls?


1. Delete all *.edm files or backup them in such way that game is not going to see them.
2. Start eDuke32 Atomic Edition (eduke v7335)
3. Go to game options and turn recording on.
4. Start new game (L.A. Meltdown with Come get some difficulty)
5. Play the game for >3s.
6. Go to Game options and turn demo recording off.
7. Quit to title.


1. Intro animation,
2. Recoded demo loads and starts to play,
3. Demo crashes after <3s of playback,
4. Crash causes game to quit to system desktop.

Please see attached demo that crashes and log file.

73Backend / CoreBug ReportVery LowCriticalEduke32 source code won't compile (revision 7138, 3 Nov...Unconfirmed
Task Description

The attached log demonstrates that the current revision (7138, 3 November 2018) of eDuke32’s source code will not compile on my machine. I’m using gcc 5.4.0 on Ubuntu 16.04 64-bit. See the attached terminal log.

In fact, eDuke32 has not compiled for me since revision 7078 (16 October 2018), though the source file that gives the error and the compiler message has changed since then. I attach a log of that as well in case that helps.

72Backend / CoreBug ReportVery LowLowDialogue missing during Episode 3 ending Unconfirmed
Task Description

At the end of Episode 3, after completing the Stadium boss fight and watching the cutscene, Duke merely says “My name is Duke Nukem”, instead of the expected full speech “My name is Duke Nukem, after a few days R&R...(etc)”

I have tested this using a clean install of the latest build (EDuke32 r7067
Built Oct 10 2018 14:07:44, GCC 7.2.0, 64-bit)

71Backend / CoreBug ReportVery LowHighproblems with midi music in linuxUnconfirmed
Task Description

Hello everyone starting from the version 20180129-6627 there are problems with the midi music in linux. My operating system is Arch Linux. The latest version of duke32 that works well is 20180128.r6613. You can do some tests with this package:

69Backend / CoreBug ReportVery LowLowRidiculous number of enemies left in Lunar Apocalypse->...Unconfirmed
Task Description

After completing Fusion Station, the game report that I left 65425 enemies. Is this an error?

The problem is reproducible on my machine.

A 34 meg video is available if you want to see it. I recorded it on my iPad and took a freezeframe from it for you to see here.

68Backend / CoreBug ReportVery LowLow-m doesn't disable enemiesUnconfirmed
Task Description

In the eduke32 -help output as well as in the online wiki, it is documented that:

eduke32 -m

should disable all monsters. But it doesn’t.

I have attached the output log.

67Backend / CoreBug ReportVery LowLowLink errors after svn update without make cleanUnconfirmed
Task Description

Hello, everyone. After updating my working copy of the source code from revision 6688 to 6722, I attempted to make the executables, and got many link errors. This implies that the makefile does not adequately list the dependencies for each object file. I enclose my terminal output. It worked fine after I ran a make clean.

66Backend / CoreBug ReportVery LowLowloading a savegame removes level lightsUnconfirmed
Task Description

i loaded up the duke burger level via the console (changelevel 4 2), saved the game immediately, and proceeded to take a screenshot with fraps
the first screenshot shows the level on first load , showing level lights and dynamic lights

then i reloaded the savegame and took another screenshot
the other screenshot shows the level after reloading , showing only dynamic lights with missing level lights

65Backend / CoreFeature RequestVery LowLowMovable Level StatsUnconfirmed
Task Description

This is merely a request to make it possible to set where on the screen the Level stats appear on the screen when enabled. I ask this as certain mods with custom huds (particularly older ones) are not really compatible with the default location, and tend to cover them up or vice-versa. But instead of just moving it right or up or down and leaving it at that, I’m wondering if it’s possible to enable an option to direct where the level stats display depending on what the custom hud is.

64Backend / CoreBug ReportVery LowLowSmall memory leaks fixUnconfirmed
Task Description

Hi here a little patch proposal to fix small mem leaks found. Cheers.

63Backend / CoreBug ReportVery LowLowEVENT_ANALYZESPRITES does not work in mapster32Unconfirmed
Task Description

This code should change the tile picnum during the deplay process. In the old version (Mapster32 2.0.0devel r4488 (32-bit) Compiled May 28 2014 15:48:34), this method works correctly. In the version (Mapster32 r6332 Built Jul 6 2017 07:49:55, GCC 6.3.0, 32-bit) it does not work.

    for i drawnsprites {
        ife tsprite[i].picnum ITEM {
            ifg tsprite[i].extra 0 set tsprite[i].picnum tsprite[i].extra
62Backend / CoreBug ReportVery LowMediumEduke32 doesn't remember vsync on setting when starting...Unconfirmed
Task Description

When starting eduke32(with polymer HRP) and then start a saved game, the game will start with vsync off.
Though in the menu its on.
Turning vsync in the menu off and on again, will solve this problem.
This only happens when starting saved games, directly after eduke32 started.
With new games there is no problem.

61Backend / CoreBug ReportVery LowCriticalCrash during sound initialisation r6301 with map from a...Unconfirmed
Task Description


With vanilla 1.5 duke3d and no other files loaded
Crash during sound initialisation.
This also happens using v1.3d .grp file as well.
Please find attached full crash log (from debugging build) and copy of map.

Critical part of log:

Initializing sound... 32 voices, 2 channels, 16-bit 48000 Hz
g_errorLineNum: 0, g_tw: 0
58Backend / CoreBug ReportVery LowLowPipebombs thrown from the water's surface stay on the s...Unconfirmed
Task Description

Using Eduke32 20170423-6129, Go into Raw Meat (E3L1) and throw pipebombs into the pool of water using the classic renderer with mouse vertical aiming off.

1. If you throw a pipebomb from the grass into the water, it will sink into the water
2. If you throw a pipebomb while you’re floating on the surface, it will “stay” on the surface.

You can see a small pipebomb sprite on the surface of the water when this happens, but only in the classic renderer.

This happens in the latest build of Eduke32.

57Backend / CoreFeature RequestVery LowMediumIndividual Color Channel Gamma/Brightness/Contrast Sett...Unconfirmed
Task Description

So like how you have the general color settings for Brightness, Gamma and Contrast, is it possible to make these for Red, Green and Blue color channels too?

I posted a bug about my NVidia Control Panel’s settings not being recognized by EDuke32/Mapster32 unless the contrast is set to 0, but about possible idea to approach this is having Color-Channel based settings [similar to how the NVidia Control Panel does it].

Granted I don’t know how well connected with NVidia feature the engine is these days, but I guess it doesn’t hurt to ask about it. :V

56Backend / CoreBug ReportVery LowMediumEDuke32 does not obey NVidia Control Panel's Color Sett...Unconfirmed
Task Description

Basically, with my new laptop, the screen’s default color calibration is off from normal, and I don’t got the $ to try to gamble on replacing the screen with a better one, so I used NVidia Control Panel’s individual color settings to offset the colors [mostly the blue part] to more acceptable colors. Unfortunately, under normal circumstances, loading EDuke32/Mapster32 will force the old color calibration settings while running it [and only while the window is selected, as it will show the proper color calibration outside of it].

The only workaround I’ve come up with for this is to setting the in-game/engine Contrast to 0.0 in the console [”vid_contrast 0”] which somehow re-inforces my Control Panel Color settings over EDuke32, however this does weird things to the gamma setting in certain ranges [like between 0.85 and 1.17, the screen will be very faded out, while otherwise, the game is brighter than normal gamma and changing it has very little effect], so you don’t have as fine tuned control over it as you’d like, and brightness is completely uneditable when the contrast is 0 too.

Another issue is even if I do this in Mapster32, going into 2D mode always unsets the contrast in 2D mode and thus forces the original screen color calibration, forcing me to set the contrast to 0 for 2D mode each time. It also doesn’t seem to save the 3D mode contrast when I leave the program, so I have to reset it once for 3D mode each time I run Mapster32.

55Backend / CoreBug ReportVery LowMediummultiplayer - some actions out of syncUnconfirmed
Task Description

for example I run 2 players on my PC, level 1 opened the curtains and blew a hole in the movie screen. the player that did this could se the curtains open as per normal but the other player saw the curtains still closed, but could see player 1 walk through

54Backend / CoreBug ReportVery LowMediummultiplayer- viewscreens teleportUnconfirmed
Task Description

using a viewscreen in multiplayer teleports you to where the camera is

53Backend / CoreBug ReportVery LowLowCommand line options, difficulty settingsUnconfirmed
Task Description

-s command line parameter doesn’t seem to work, it doesn’t change the difficulty (skill) in settings.cfg; I can only change it via game menu by starting new game with the difficulty I want.
Also, if I launch the game with -s4 (Damn I’m Good, respawning enemies), then it doesn’t change the difficulty (in terms of enemies/objects placement) but enemies WILL respawn.

52Backend / CoreBug ReportVery LowLowMap shade preview does not restore pal/shade when disab...Unconfirmed
Task Description

no task description

51Backend / CoreFeature RequestVery LowLowThe ability to define/undefine adult mode tilesUnconfirmed
Task Description

From the looks of the source, this was intended to be changed at some point:

// XXX: this fucking sucks and needs to be replaced with a SFLAG
static int G_CheckAdultTile(int tileNum)

I have some x-rated tiles in my mod that I wish to define as adult mode tiles. I’m currently doing this with a hacky workaround, which only allows setting adult tiles, and not the other way around... but I’d be nice to be able to set and unset which tiles are considered “adult” natively.

Why the ability to un-set them? Well, if a mod is a completely new game with new tile arrangements, it’s pretty obvious why. Another reason, I want to be able to make Adult mode a toggle for the x-rated content, while keeping everything else intact (like gore).

Showing tasks 1 - 50 of 78 Page 1 of 21 - 2 -

Available keyboard shortcuts


Task Details

Task Editing