• Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System Linux
  • Severity High
  • Priority Very Low
  • Reported Version Development
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: EDuke32
Opened by Peter Bond - 2019-09-05

FS#90 - Trapped in Toxic Dump shrink room


I downloaded eduke32 rev 8075 and compiled on linux and started playing Duke Nukem 3D.

It worked great and was fun until I reached level “Toxic Dump” with the shrink room: At some point you get a red key card which unveils a shrinker. You have to run shrunk through a small tunnel into another room with a shrinker. In that room there’s a switch which opens a door outside. The only way to enter and to leave that room is shrunk. So you need the shrinker in that room to get out again. With rev 8075 it is not possible because the shrinking beam doesn’t leave the wall. You’re trapped.

I checked out a couple of older revisions (which had issues with incompatible savefile versions and stuff). I ended up with revision 7500 that worked for me. With revision 7500 the shrink beam leaves the wall, I could get shrunk and leave the room. After getting past this point I saved and got back to revision 8075.

I attached a savefile where you in the shrink room. Just load it with revision 7500 and 8075 and you will see the difference with the shrink beam.


Available keyboard shortcuts


Task Details

Task Editing