Notice: A non well formed numeric value encountered in /var/www/bugs.eduke32.com/includes/class.flyspray.php on line 105 Notice: A non well formed numeric value encountered in /var/www/bugs.eduke32.com/includes/class.flyspray.php on line 105 Notice: A non well formed numeric value encountered in /var/www/bugs.eduke32.com/includes/class.flyspray.php on line 105 FS#62 : Eduke32 doesn't remember vsync on setting when starting saved game

EDuke32

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System Windows
  • Severity Medium
  • Priority Very Low
  • Reported Version Development
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: EDuke32
Opened by Dennis Deurhof - 2017-07-15

FS#62 - Eduke32 doesn't remember vsync on setting when starting saved game

When starting eduke32(with polymer HRP) and then start a saved game, the game will start with vsync off.
Though in the menu its on.
Turning vsync in the menu off and on again, will solve this problem.
This only happens when starting saved games, directly after eduke32 started.
With new games there is no problem.

Destineer Rush commented on 2017-09-16 01:27

Noticed this issue on Linux as well, so I looked into it.

Long story short, the fix is in `source/duke3d/src/game.cpp`. Cut line 6467 (which is a call to `system_getcvars()`) and move it down about 12 lines to just after the call to `Bfree()`, then recompile. This resolved the issue for me and vsync is now correctly set at launch.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing