EDuke32

IDCategoryTask TypePrioritySeveritySummaryStatusProgress
4Backend / CoreBug ReportVery LowHighController IssuesUnconfirmed
0%
Task Description

Using a gamepad results in odd behavior. There is always a tilt to Duke’s movements, or to put it another way there is no zero. Changing the sensitivity offsets this, but the sensitivity also reveals how out of balance it is. at 26% and below it leans to the left, and at 27% and above it leans to the right. It also appears to completely ignore the existence of the second stick, using it as four buttons rather than...well, a stick. Oddly, it still shows up as an axis in the joystick settings, though modifying it does nothing.

5Backend / CoreBug ReportVery LowLowSprites disappearing/acting weird in Polymost rendererAssigned
0%
Task Description

https://forums.duke4.net/topic/8188-switch-flickeringdisappearing-in-spaceport-polymost/page__view__findpost__p__232761

https://youtu.be/JTShurhZMxI

Yeah... I recorded those bugs in action, with r5628...map is RED2 (2014 remake) again. :P

Missing alphabet sprites(the WC “sign” just disappeared so I forgot that’s a goddamn WC room when I play the new version of map), and gaps on the both sides of security camera “box”......

Classic renderer just fine...
https://youtu.be/vBqm0NvjdBw

It seems many maps with sprites may have such issues...and sometimes will randomly happens after played some levels in eduke32 about half-hour and more.

7Backend / CoreBug ReportMediumLowParental lock can't be disabled once enabledNew
0%
Task Description

Parental lock can’t be disabled once enabled. When enabling parental lock, the password is correctly saved to the .cfg, but the password does not work to turn parental lock back off.

8Backend / CoreBug ReportVery LowMediumView clipping glitchUnconfirmed
0%
Task Description

I notice at certain points in certain levels active sprites will disappear and you can see through walls. Attached are a series of screenshots showing the precise location I was able to intentionally make this happen in E2L4. Standing on the edge of the bridge object, which is embedded within the geometry a little bit, seems to be a repeatable way to get this reaction. I have, however, triggered it unintentionally far more but because it happens for but an instant I am unable to screencap fast enough.

I wasn’t sure if this was related to the other sprite issues, but I saw no mention of the clipping so I reported this by itself.

9Backend / CoreBug ReportVery LowLowLevitating SpritesUnconfirmed
0%
Task Description

I’ve noticed certain sprites (it appears to be random) will appear at a level significantly higher than where they’re supposed to be. Attached is a picture of a fire floating freely through the air. I have observed enemy sprites do this as well. I’m not sure where their collision box is.

This is so far in the software render. Untested with graphic acceleration.

10Backend / CoreBug ReportVery LowLowSpecular maps affected too directly by scene lightingUnconfirmed
0%
Task Description

As per the summary specular maps are too heavily effected by the scene lighting which results in an almost pearlescent paint effect.

11Backend / CoreFeature RequestVery LowLow.FBX file supportDeferred
0%
Task Description

This is a request for the fbx model format to be supported along side md3s.

This format has way more features such as skeletal animations and is more easily created by most 3D applications.

I believe supporting a more popular file format will encourage others to contribute to projects.

13Backend / CoreBug ReportVery LowCriticalLots of renderer problems in polymostUnconfirmed
0%
Task Description

I tested polymost mode in latest EDuke 32 and found lots of problems.

Problem 1: screwed up masked walls. It happens of every level, they look really messed up. I suppose the developers know about this problem already, but just wanted to have it on the list.

Problem 2: weird lighting on certain walls. Happens a lot, for example here’s a gif from E2L1

Problem 3: Fog doesn’t work in polymost. Tested on E2L1 of Infestation In Time TC

Polymost (fog doesn’t work)
cs628628.vk.mev6286288723d0a3cwnh_t3qoim.jpg

Polymer (works fine)
cs628628.vk.mev6286288723d0acxogv-3v-toy.jpg

My PC specs:

Win 7 x86
GeForce GTX 550
AMD Athlon 2 2 x4 640

17Backend / CoreBug ReportVery LowLowSprite Layering IssueUnconfirmed
0%
Task Description

Object sprites have a strong tendency to be rendered behind special objects and in front of level geometry.

18Backend / CoreBug ReportVery LowLowSprites like Blood pools(Green-waste pools, footprints ...Unconfirmed
0%
Task Description

https://forums.duke4.net/topic/8565-sprites-like-blood-poolsgreen-waste-pools-footprints-etc-lose-alpha-transparents-in-automap/

Sorry, I’m lazy to test more and finding out which revision broke that. :\

20Backend / CoreBug ReportVery LowHighWarping in overlapping sectorsUnconfirmed
0%
Task Description

Something that’s become a rather large problem as of late are enemies, objects, and even myself, the player, just glitching through overlapping sectors in that fake room-over-room style. This isn’t just an effect on fan-maps; official maps such as L.A. Rumble and especially Tier Drops and Lunatic Fringe (in the case of the latter it being the difference between you escaping with your life and then being teleported right back into danger to be perforated by a Battlelord) suffer from it as well.

22Backend / CoreBug ReportVery LowMediumTexture rendering issue with PolymerUnconfirmed
0%
Task Description

I’m noticing some textures being clipped when looked at from certain angles. There’s a good example of this in Hollywood Holocaust with the Sister Act II poster with in the theater with the lights on. Whenever I look around the area from a certain angle, the poster would get cut off in weird ways.

24Backend / CoreBug ReportHighHighPerfect Ornamented SpritesResearching
0%
Task Description

Hardware accelerated renderers need wall-aligned and floor-aligned sprites to get ornamented to surfaces with no clipping or performance regressions.

25Backend / CoreBug ReportVery LowMediumMissing World Geometry Using Polymer RendererUnconfirmed
0%
Task Description

In some levels with the Polymer renderer being used, world geometry will not be drawn, with the sky showing through these openings. It has a tendency to happen on certain maps, but can also happen completely at random. I took the screenshots from the first level of NAM because it is basically right in front of you when you start and happens every single time. I have also encountered situations where geometry that was present will not be present when a level is saved and loaded.

27Backend / CoreBug ReportVery LowLow64-bit version doesn't use the system MIDI deviceUnconfirmed
0%
Task Description

Windows 8.1 x64. The default MIDI device is loopMidi.
Works fine with 32-bit EDuke32 and other applications like DosBox, but the 64-bit EDuke32 uses some primitive synthesizer instead. loopMidi shows zero throughput.

29Backend / CoreBug ReportVery LowCriticalMac version Keeps CrashingUnconfirmed
0%
Task Description

Dear EDuke32 Support,

I seem to have trouble playing EDuke32 on my MacBook Pro. I have the official GOG version and playing it by itself is okay but when I use EDuke32 the game would crash. This seems to only happen when I play the game the second time. The game screen turns black, my Mac makes this buzzing sound and nothing happens. I had no choice but to press the power button to restart my Mac.

The following are the details of my Mac (also attached is my System Report for your perusal):

OS X El Capitan (v 10.11.6)
MacBook Pro (15-inch, Late 2011)
Processor: 2.2 GHz Intel Core i7
Memory: 8 GB 1600 MHz DDR3
Startup Disk: Macintosh HD
Graphics: AMD Radeon HD 6750M 512 MB

Several things I tried doing to solve the problem:

  1. I followed the EDuke32 wiki page and copied the DUKE.RTS and DUKE3D.GRP files (which I got from the PC version of Duke3D GOG) into the [Application Support –> EDuke32 folder]. It works but again it crashes on the second playthrough.
  2. I copied the EDuke32 app into the Duke 3D GOG app (Duke Nukem 3D.app –> Show Package Contents –> Contents –> Resources) and once again, it only works on the first playthrough.

I used the OS X Lion version of EDuke32 (eduke32_osx-sdl2_lion_svn5811.dmg | The Jul 12 2016 version) to play the game. What am I doing wrong? Or is there an actual bug on the Mac version?

Appreciate if anyone can help identify the problem and provide a solution to it.

Hope to hear from you promptly.

Sincerely,
KrisFrosz133

30Backend / CoreBug ReportVery LowLowWindow size limitUnconfirmed
0%
Task Description

My monitor’s native resolution is 2560×1600. Fullscreen works perfectly fine, but the highest windowed resolution I can set is 1920×1440.

Manually changing the config doesn’t work. What does work is starting the game in fullscreen, then pressing Alt+Enter, resulting in a borderless fullscreen window.

31Backend / CoreBug ReportVery LowHighNo playing musicUnconfirmed
0%
Task Description

again...

Showing tasks 1 - 18 of 18 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing