EDuke32

IDCategoryTask TypePrioritySeveritySummaryStatusProgress
4Backend / CoreBug ReportVery LowHighController IssuesUnconfirmed
0%
Task Description

Using a gamepad results in odd behavior. There is always a tilt to Duke’s movements, or to put it another way there is no zero. Changing the sensitivity offsets this, but the sensitivity also reveals how out of balance it is. at 26% and below it leans to the left, and at 27% and above it leans to the right. It also appears to completely ignore the existence of the second stick, using it as four buttons rather than...well, a stick. Oddly, it still shows up as an axis in the joystick settings, though modifying it does nothing.

5Backend / CoreBug ReportVery LowLowSprites disappearing/acting weird in Polymost rendererAssigned
0%
Task Description

https://forums.duke4.net/topic/8188-switch-flickeringdisappearing-in-spaceport-polymost/page__view__findpost__p__232761

https://youtu.be/JTShurhZMxI

Yeah... I recorded those bugs in action, with r5628...map is RED2 (2014 remake) again. :P

Missing alphabet sprites(the WC “sign” just disappeared so I forgot that’s a goddamn WC room when I play the new version of map), and gaps on the both sides of security camera “box”......

Classic renderer just fine...
https://youtu.be/vBqm0NvjdBw

It seems many maps with sprites may have such issues...and sometimes will randomly happens after played some levels in eduke32 about half-hour and more.

8Backend / CoreBug ReportVery LowMediumView clipping glitchUnconfirmed
0%
Task Description

I notice at certain points in certain levels active sprites will disappear and you can see through walls. Attached are a series of screenshots showing the precise location I was able to intentionally make this happen in E2L4. Standing on the edge of the bridge object, which is embedded within the geometry a little bit, seems to be a repeatable way to get this reaction. I have, however, triggered it unintentionally far more but because it happens for but an instant I am unable to screencap fast enough.

I wasn’t sure if this was related to the other sprite issues, but I saw no mention of the clipping so I reported this by itself.

9Backend / CoreBug ReportVery LowLowLevitating SpritesUnconfirmed
0%
Task Description

I’ve noticed certain sprites (it appears to be random) will appear at a level significantly higher than where they’re supposed to be. Attached is a picture of a fire floating freely through the air. I have observed enemy sprites do this as well. I’m not sure where their collision box is.

This is so far in the software render. Untested with graphic acceleration.

10Backend / CoreBug ReportVery LowLowSpecular maps affected too directly by scene lightingUnconfirmed
0%
Task Description

As per the summary specular maps are too heavily effected by the scene lighting which results in an almost pearlescent paint effect.

11Backend / CoreFeature RequestVery LowLow.FBX file supportDeferred
0%
Task Description

This is a request for the fbx model format to be supported along side md3s.

This format has way more features such as skeletal animations and is more easily created by most 3D applications.

I believe supporting a more popular file format will encourage others to contribute to projects.

17Backend / CoreBug ReportVery LowLowSprite Layering IssueUnconfirmed
0%
Task Description

Object sprites have a strong tendency to be rendered behind special objects and in front of level geometry.

20Backend / CoreBug ReportVery LowHighWarping in overlapping sectorsUnconfirmed
0%
Task Description

Something that’s become a rather large problem as of late are enemies, objects, and even myself, the player, just glitching through overlapping sectors in that fake room-over-room style. This isn’t just an effect on fan-maps; official maps such as L.A. Rumble and especially Tier Drops and Lunatic Fringe (in the case of the latter it being the difference between you escaping with your life and then being teleported right back into danger to be perforated by a Battlelord) suffer from it as well.

22Backend / CoreBug ReportVery LowMediumTexture rendering issue with PolymerUnconfirmed
0%
Task Description

I’m noticing some textures being clipped when looked at from certain angles. There’s a good example of this in Hollywood Holocaust with the Sister Act II poster with in the theater with the lights on. Whenever I look around the area from a certain angle, the poster would get cut off in weird ways.

24Backend / CoreBug ReportHighHighPerfect Ornamented SpritesResearching
0%
Task Description

Hardware accelerated renderers need wall-aligned and floor-aligned sprites to get ornamented to surfaces with no clipping or performance regressions.

25Backend / CoreBug ReportVery LowMediumMissing World Geometry Using Polymer RendererUnconfirmed
0%
Task Description

In some levels with the Polymer renderer being used, world geometry will not be drawn, with the sky showing through these openings. It has a tendency to happen on certain maps, but can also happen completely at random. I took the screenshots from the first level of NAM because it is basically right in front of you when you start and happens every single time. I have also encountered situations where geometry that was present will not be present when a level is saved and loaded.

27Backend / CoreBug ReportVery LowLow64-bit version doesn't use the system MIDI deviceUnconfirmed
0%
Task Description

Windows 8.1 x64. The default MIDI device is loopMidi.
Works fine with 32-bit EDuke32 and other applications like DosBox, but the 64-bit EDuke32 uses some primitive synthesizer instead. loopMidi shows zero throughput.

29Backend / CoreBug ReportVery LowCriticalMac version Keeps CrashingUnconfirmed
0%
Task Description

Dear EDuke32 Support,

I seem to have trouble playing EDuke32 on my MacBook Pro. I have the official GOG version and playing it by itself is okay but when I use EDuke32 the game would crash. This seems to only happen when I play the game the second time. The game screen turns black, my Mac makes this buzzing sound and nothing happens. I had no choice but to press the power button to restart my Mac.

The following are the details of my Mac (also attached is my System Report for your perusal):

OS X El Capitan (v 10.11.6)
MacBook Pro (15-inch, Late 2011)
Processor: 2.2 GHz Intel Core i7
Memory: 8 GB 1600 MHz DDR3
Startup Disk: Macintosh HD
Graphics: AMD Radeon HD 6750M 512 MB

Several things I tried doing to solve the problem:

  1. I followed the EDuke32 wiki page and copied the DUKE.RTS and DUKE3D.GRP files (which I got from the PC version of Duke3D GOG) into the [Application Support –> EDuke32 folder]. It works but again it crashes on the second playthrough.
  2. I copied the EDuke32 app into the Duke 3D GOG app (Duke Nukem 3D.app –> Show Package Contents –> Contents –> Resources) and once again, it only works on the first playthrough.

I used the OS X Lion version of EDuke32 (eduke32_osx-sdl2_lion_svn5811.dmg | The Jul 12 2016 version) to play the game. What am I doing wrong? Or is there an actual bug on the Mac version?

Appreciate if anyone can help identify the problem and provide a solution to it.

Hope to hear from you promptly.

Sincerely,
KrisFrosz133

30Backend / CoreBug ReportVery LowLowWindow size limitUnconfirmed
0%
Task Description

My monitor’s native resolution is 2560×1600. Fullscreen works perfectly fine, but the highest windowed resolution I can set is 1920×1440.

Manually changing the config doesn’t work. What does work is starting the game in fullscreen, then pressing Alt+Enter, resulting in a borderless fullscreen window.

32Backend / CoreBug ReportVery LowCriticalr4897 introduces startup crash on some architecturesUnconfirmed
0%
Task Description

I have been using r5485 32 bit for some time on a modern laptop (i7, 12GB, Intel HD 4.3.0 / GTX 850) for some time. Copied EDuke32 installation to my backup laptop (i3, 4GB, very basic Intel graphics) and it crashes on startup. I get some OpenGL feature-not-present warnings, as expected for a machine of this age/class, but wasn’t expecting it to crash.

Bisected timeline using debug builds, change was introduced in r4897; previous build works fine. Tested with out-of-the-box install, no HRP, no addons, no settings changes. Extract, copy in atomic duke3d.grp, run eduke32, click start button in startup dialog making no settings changes whatever.

Crash log, CPU-Z and MSINFO32 reports attached.

34Backend / CoreBug ReportVery LowLowaddons folderUnconfirmed
0%
Task Description

Hello,

actually I have two way to launch addons with eduke 32:

1) put all fikes (grp and maps) into the eduke32 main folder or in the config folder.
2) launch eduke32 with -j /full_path_to_folder_with_grp

Could you add another cleaner way please?

Like this one:

Eduke could search for an /addons folder located in his main folder (executable folder) or in his config folder (/home/username/.eduke32 for linux).

36Backend / CoreBug ReportVery LowMediumTROR editing camera jumpingUnconfirmed
0%
Task Description

When editing some walls in mapster, such as inserting new points or dragging points around, this often causes the camera to jump vertically. This usually has an effect on the vertical editing zone that you’ve created by pressing ctrl-r while a sector is highlighted, causing everything to become greyed out which slows down mapping. It’s also annoying to have to return to the room you’re working on in 3D mode after a jump. Obviously this happens in areas where you have sectors stacked on top of each other.

38Backend / CoreBug ReportVery LowVery LowHardcoded actor bugUnconfirmed
0%
Task Description

Hrdcoded SLIMER actor bugged behaviour: When you shoot FREEZEBLAST at SLIMER, it freezes, but actors_killed variable increments at the same time. Thus you can increase actors_killed value by freezing/thawing SLIMER over and over.
Suggestion/Solution:
actor.c: line 4336 should be moved after “if” statement at line 4341 (don’t increment actors_killed if slimer was freezed);
actor.c: line 4336 should be copied right after the line 4215 (increment actors_killed if frozen slimer is shattered);

40Backend / CoreBug ReportVery LowLowMenu/Interface GlitchAssigned
0%
Task Description

EDuke menu captions doesn’t support non-latin symbols (because font is a pile of tiles representing only latin symbols, digits and some punctuation marks). If I go under “User Map” menu section, browse file system with internal file explorer and find a folder/file with non-latin symbols in its name, I get a glitch (wrong tile in place of non-latin symbol), because of an incorrect offset. I attach a screenshot of this glitch.

41Backend / CoreBug ReportVery LowHighPlayer gibs on spawn, even in fake multiplayerUnconfirmed
0%
Task Description

This is a known bug, but I think I may know why it’s happening.

In fake MP (either with bots or not) players (usually the first player and one other) will end up gibbing on spawn. I’ve noticed that sometimes you’ll end up seeing your view move on it’s own, as if you’re being “controlled” by another player. I’m wonder if this long-standing bug might be because two players are trying to occupy the same body and are sharing input, or at least being tied to the same spawn, thus the weird “being taken control of” bug and the telefragging on spawn.

I’ve also noticed that the first player doesn’t spawn in the initial spawn point (brown arrow in mapster32) at the start of a map like they are normally supposed to either.

I know the multiplayer is far from complete, but I hope this could at least be looked at in the interim so I can at least play some botmatches.

42Backend / CoreBug ReportVery LowMedium"Duke Talk" Sound block should be per-actor, not global...Unconfirmed
0%
Task Description

Sounds with the Duke Talk bit enabled have a bit of code that blocks another Duke Talk sound from playing if any Duke Talk is already playing. This is normal, but there’s a bit of a bug/oversight with it. With the way it is now, in Multiplayer, only one player can play pain or death sounds at a time. If someone is being damaged, it’ll block other players from making noise. Same can happen in singleplayer if you have useractor that uses Duke Talk. What I suggest, is adding an additional check so it blocks on a per-actor basis, so only one sound can play per actor, and not one sound globally. This check wouldn’t apply if GlobalSound is being used, however, for obvious reasons.

44Backend / CoreFeature RequestVery LowLow"actorsound" CON functionUnconfirmed
0%
Task Description

Right now, EDuke32 has stopactorsound, and ifactorsound, but no actorsound function. I can think of many scenarios where it would not only be nice to stop other actors from playing sounds/check if they are playing a sound, but also make other actors start playing sounds.

This could be used to make Duke Talk play from the attacking player (without the need of flimsy, ugly hacks), instead of globally. It can also be used to make an enemy that uses a psychic attack that makes the target emit a high-pitched sound before causing it to explode, scanners-style. Or, it could be used to make items that cause the player picking it up to make a sound that’s audible to other players.

45Backend / CoreBug ReportVery LowMediumController issues, againUnconfirmed
0%
Task Description

Several issues with controllers:

- Double tap commands set by default cannot be unbound, even by editing the file settings with a text editor. This is a bug I noticed in 2010 AFAIK and that is still occurring in 2016!
- With an Xbox 360 controller, Axis 3 and 4 are respectively bound to Axis 0 and 1, meaning that two commands are bound to the same analog stick. Also, setting a correct sensitivity in order to not to have Duke spinning as hell is nearly impossible.

46Backend / CoreFeature RequestVery LowLowRemove the Episode LimitUnconfirmed
0%
Task Description

7 Episodes seems to be a rather arbitrary limit to the number of allowed episodes...

I suggest raising it to 255/removing the limit. Also, for the singleplayer episode select screen, just add a “next page” option, or allow the page to scroll if there’s too many episodes to fit the menu.

47Backend / CoreFeature RequestVery LowLowPROJECTILE_RIPPER flag for PROJ_WORKSLIKEUnconfirmed
0%
Task Description

Like suggested here: https://forums.duke4.net/topic/9021-con-coding-help/page__view__findpost__p__266961

I wish for a PROJECTILE_RIPPER flag to make penetrating hitscans (like railguns) and ripping projectiles (projectiles that pass through enemies, doing damage along the way) a possibility.

Showing tasks 1 - 25 of 25 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing